Tomi Roine

Polttava dvd-asema lakkasi toimimasta

13 viestiä aiheessa

Pahoittelen näitä pitkiä lainauksia, mutta itselle kävi näin ja vastauksen etsiminen vaati usemman tunnin googletusta. Kannattaa varmaan tarkistaa onko allaolevista ongelmista kysymys ennen kuin keität vehkeet romukoppaan.

 

"Fix for no DMA only PIO mode for Toshiba SD-R1102 DVD/CD-RW Combo

To enable DMA for my DVD and CD-RW I had to "disable" these two drives in BIOS (I simply selected "None" instead of "Auto"). After that I was able to use DMA in XP, without installing VIA drivers that is! Don't know if it will help you, but it's worth trying I guess.

 

this fix is for everyone using Windows XP and can't enable DMA for CDROM or hard disk. If you are sure that your cdrom supports DMA mode then run regedit, press "Edit--Find" and there put the word "timingmode". Regedit will search the registry and find the two ide buses. You will recognize these easily. It is written primary and secondary, master and slave. In my case my Toshiba DVD was running in PIO mode instead of DMA and was located in primary slave. I changed the value of two strings including the TimingMode for primary slave. The value for DMA33 is 8208 (decimal). Furthermore the second string must be ffffffff. I found every string with TimingMode that refered to primary slave and made these changes. After restarting Windows DMA33 was enabled!!!"

 

"DMA Reverts to PIO

General Description

DMA is an abbreviation for Direct Memory Access, an access method for external devices where the data transfer is not done by the central processor, but by a small special processor called DMA controller. It uses a procedure called cycle stealing, where the central processor memory access cycles are delayed for very short times to intersperse DMA controller memory access cycles. Some newer, faster DMA modes are called UDMA (Ultra DMA).

 

The alternative, slow and inefficient data transfer mode is called PIO, Programmed Input-Output, where the central processor transfers data byte for byte or word for word. This requires many processor commands for each data word and therefore causes a high and unwanted processor load.

 

Windows contains a trap in which quite a few computers seem to get caught sooner or later. The trap is described in the following article (and also in another one mentioned below):

 

DMA Mode for ATA/ATAPI Devices in Windows XP

http://www.microsoft.com/whdc/hwdev/tech/storage/IDE-DMA.mspx

 

The crucial paragraphs are:

 

PIO mode is enabled by default in the following situations:

...

For repeated DMA errors. Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.

 

In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.

 

Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).

...

 

Of course, drive firmware being quite complex and certainly containing programming defects of its own, it is not all that difficult to produce such errors. In my case a scratched DVD and later also an unreadable (overburned) CD did the trick, got the drive to choke and Windows to disable DMA for good. Later my hard disk hiccupped just once and also went back to PIO for good.

 

I had been using my laptop for DVD viewing for years, until I inserted a borrowed and heavily scratched DVD. The player and apparently even the DVD drive choked on it, and when I finally got the DVD to play, I found that playing was jerky and processor load was 100%, roughly half of which was system overhead.

 

This indicated that the drive had reverted from the usual UDMA (Ultra Direct Memory Access) mode 2 to PIO (Programmed Input Output) mode. No amount of resetting or changing the relevant registry parameters from 1 (try DMA) to 2 (force DMA) helped. Stubbornly the drive kept using PIO mode, and Windows even changed these settings back to 0 (use PIO only).

 

The following text will refer to the secondary IDE port because that is more often affected, but essentially the same also holds for the primary IDE port, to which the main hard disk is connected in most computers.

 

Check Your IDE Port Mode

First check what mode your secondary IDE port is currently working in. Go to Device Manager: right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and check whether it is set to DMA when available. Directly underneath that setting is a grey field that shows the actual working mode of your IDE channel. You want the highest possible DMA or Ultra DMA mode there, and you definitely don't want PIO mode.

 

Normally you don't have to use the registry editor for this, because the normal settings are also available through the properties dialog for the IDE port, but if you want to look at it anyway, the parameter for the secondary IDE port can be found through regedit.exe at

 

HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1

 

It is named Scsi only for historic reasons. Scsi Port 0 is the primary IDE port, to which presumably your hard disk is connected.

 

After trying various remedies—in vain—I found the abovementioned article and went to work again. I uninstalled the DVD drive in Device Manager and rebooted, but that did not help either.

 

So I searched for more and better information, then I went on and did the following.

 

Re-enable DMA using the Registry Editor

My thanks go to my fellow MVP Alexander Grigoriev who taught me this method.

 

Run REGEDIT. Go to the following key:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

 

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

 

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

 

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

 

Alternative Method—Uninstalling the Port

1. Uninstall the secondary IDE port

To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

 

Reboot to make the changes active and permanent.

 

After this first reboot Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

 

2. Reactivate DMA

But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

 

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

 

Now you have to reboot a second time, then you can go to the same place in Device Manager and check whether the device is now actually using DMA mode. If so, all is well.

 

Desensitize Your Computer's IDE Channels

There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

 

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur

http://support.microsoft.com/?kbid=817472

 

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

 

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive.

 

German version of this page

Back to table of contents"

 

Jaa viesti


Link to post
Jaa muulla sivustolla

Minulla on taas sellainen ongelma LG:n aseman kans, että se suostuu lukeen levyjä vain silloin tällöin. Asema kyllä tunnistaa että levy on mutta ei suostu lukemaan kun vasta pitkän tappelun jälkeen. Autttaisikohan tuohon firmwaren päivitys?

Jaa viesti


Link to post
Jaa muulla sivustolla

Yleensä lukemisongelmat johtuvat hajonneesta asemasta. Se on niin perusjuttu, ettei softat sitä juuri pääse sotkemaan. Kirjoittamisongelmissa softavika on todennäköisempi. Mulla on normaali käytäntö oikkuilevan CD/DVD-aseman kanssa heittää se menemään sen kummemmin tutkimatta, kun tuntipalkoille ei pääse kumminkaan. Kirjoittavan kanssa tietty kannattaa hiukan enemmän yrittää. Jos löydät firmispäivityksen, niin asenna ihmeessä.

Jaa viesti


Link to post
Jaa muulla sivustolla

Noh kävin sen kummempia ajattelematta ostamas uuden... 49 egee dual layerillä etc herkuilla varustettu asema.

Jaa viesti


Link to post
Jaa muulla sivustolla

Terve,

 

Itselläni hajosi myös LG:n polttava dvd-cdrw asema. Ei suostunut lukemaan mitään levyjä, eikä polttaminenkaan onnistunut. Takuu oli ummessa joten ei muutakuin uutta ostamaan, kun eivät kovin kalliita ole. Nykyinen valittaa ainakin Nerolla poltettaessa että DMA tuki ei ole päällä, mutta olen poltellut siitä huolimatta. Haitanneeko tuo mitään?

 

PS. Yksikään LG ei ole minulla vielä kestänyt "loppuun asti". Ei lukevat asemat eikä polttavat. 4-5 kertaa olen kiikuttanut LG:n takuuvaihtoon. Ei kovin kestäviä laitteita nämä LG:t.

Jaa viesti


Link to post
Jaa muulla sivustolla

PS. Yksikään LG ei ole minulla vielä kestänyt "loppuun asti". Ei lukevat asemat eikä polttavat. 4-5 kertaa olen kiikuttanut LG:n takuuvaihtoon. Ei kovin kestäviä laitteita nämä LG:t.

 

Mukavaa lukea tälläisiä viestejä, kun tuli juuri muutama päivä sitten ostettua LG:n lukeva ja vielä polttavakin asema ;D Melkein sanoisin, että sinulla on ollut vain huonoa onnea.

Jaa viesti


Link to post
Jaa muulla sivustolla

Hehe, mulla on 2 LG:n asemaa ja molemmat jo varmasti kaksi vuotta ollut täydessä toiminnassa :laugh:

Jaa viesti


Link to post
Jaa muulla sivustolla

Noin 100 LG:n lukevaa ja parikymmentä polttavaa käytössä, pari aika kovassakin, vielä ei ole yksikään hajonnut...että kait se on näidenkin kanssa tuurista kiinni.

Jaa viesti


Link to post
Jaa muulla sivustolla

LG-nimellä myytävissä optisissa asemissa yhdistyy Hitachin koneisto ja LG:n maailmanlaajuinen myyntiverkosto.Ne eivät ole sen kummemmin mitään halpis-tuotteita kuin muutkaan vastaavat.Omasta kokemuksesta n.15,yhden olen vaihtanut takuuaikana,ei huonosti.Surkein kokemus optisista asemista taas on ollut se ainoa Plextor ns.merkkituote, mutta se lienee vain sattuma.

 

            Vexi

Jaa viesti


Link to post
Jaa muulla sivustolla

Mulla on taas kolme LG:tä paukkunut parin viikon mittaan. Kyllä ne vaan ovat luokattomia rupuvehkeitä, ei siitä mihinkään pääse. Yli puolet taitaa olla jo hajonnut ennen luonnollista käytöstä poistumistaan. En taatusti osta enää yhtään.

Jaa viesti


Link to post
Jaa muulla sivustolla

Luo uusi käyttäjätunnus tai kirjaudu sisään

Sinun täytyy olla jäsen osallistuaksesi keskusteluun

Luo käyttäjätili

Rekisteröi uusi käyttäjätili helposti ja nopeasti!


Luo uusi käyttäjätili

Kirjaudu sisään

Sinulla on jo käyttäjätili?


Kirjaudu sisään