Petri Koivisto

Pikku ongelma Ultimate Traffic 2:n kanssa. [FSX]

18 viestiä aiheessa

Morjesta pöytään :D

 

Eli tällästä pukkaa startissa:

 

[ attachment removed / expired ]

 

Mistäköhän johtuu? En ymmärrä missä muka on "multiple objects with the same title name" ? Tuo käy melkeen koko kansion läpi, kun pitää entteriä pohjassa niin noi kaikki loppuu ja simu aukeaa normaalisti ja AI-liikenne näkyy myöskin ilman ongelmia? Ärsyttävää vaan kun joutuu tuota entteriä painamaan startissa pitkään... ;D

 

UT2 asennettu pariin kertaan uusiksi, kun aluksi ei ollut edes Net Framework 3.5 asennettuna, sen jälkeenkin vissiin poistanut pari kertaa siinä toivossa että tuo korjaantuisi. Noiden foorumilta ja googlesta koittanut ettiä samaa ongelmaa mutta eipä ole löytynyt... Joten pakko taas turvautua tämän foorumin guruihin ;D

Jaa viesti


Link to post
Jaa muulla sivustolla

Onko sinulla mahdollisesti asennettuna esim. WOAI liikennettä? Jos on, niin kannattaa poistaa ne, että ei tulisi tuollaisia virhe ilmoituksia.

Jaa viesti


Link to post
Jaa muulla sivustolla

Onko sinulla mahdollisesti asennettuna esim. WOAI liikennettä? Jos on, niin kannattaa poistaa ne, että ei tulisi tuollaisia virhe ilmoituksia.

Oli, mutta tietääkseni poistin jo kaikki...?

Jaa viesti


Link to post
Jaa muulla sivustolla

Tarkista seuraavasta kansiosta ettei sinne ole jäänyt WOAI sälää, eli niiden koneita:

..\Microsoft Flight Simulator X\SimObjects\Airplanes

 

Jos ei WOAI koneita löydy, aiheuttaa joku toinen kone tuon herjan.

 

Eli koneiden kansiosta löytyy aircraft.cfg tiedosto jossa on jokaisen koneen maalauksen ensimmäisen rivin jälkeen esim. suraavanlainen rivi:

 

[fltsim.0]

title=Boeing 737-800 Paint1

...jne...

 

Tuo "title" rivi pitää olla joka kohdassa uniikki, muuten tulee tuo herja. Eli siihen voi vaikka laittaa koneen rekisteritunnuksen perään.

 

Kyllä se ongelman aiheuttaja sieltä löytyy, kun jaksaa etsiä. Tsemppiä!  :thmbup:

Jaa viesti


Link to post
Jaa muulla sivustolla

Tarkista seuraavasta kansiosta ettei sinne ole jäänyt WOAI sälää, eli niiden koneita:

..\Microsoft Flight Simulator X\SimObjects\Airplanes

 

Jos ei WOAI koneita löydy, aiheuttaa joku toinen kone tuon herjan.

 

Eli koneiden kansiosta löytyy aircraft.cfg tiedosto jossa on jokaisen koneen maalauksen ensimmäisen rivin jälkeen esim. suraavanlainen rivi:

 

[fltsim.0]

title=Boeing 737-800 Paint1

...jne...

 

Tuo "title" rivi pitää olla joka kohdassa uniikki, muuten tulee tuo herja. Eli siihen voi vaikka laittaa koneen rekisteritunnuksen perään.

 

Kyllä se ongelman aiheuttaja sieltä löytyy, kun jaksaa etsiä. Tsemppiä!  :thmbup:

Tjoo, poistin tuon, katsoin kaikki läpi, poistin FSX kansiosta vanhat tiedostot pois (siis roamingista) ja asensin takaisin -> sama ongelma... enkä varmasti jaksa käydä kaikkia miljoonaa kansiota läpi ja tarkistaa nuo titlet... mielummin pidän vähän aikaa entteriä pohjassa... ;D

Jaa viesti


Link to post
Jaa muulla sivustolla

Mulla oli muistaakseni joskus samanlaista ongelmaa. Mulla se aiheutui samannimisistä koneista eri kansioissa. Eli FSX:n koneet on normaalisti siellä "Microsoft Flight Simulator X\SimObjects\Airplanes" kansiossa, mutta jostainsyystä mulla oli mennyt jotain koneita "Microsoft Flight Simulator X\Airplanes" kansioon. Poistin ylimääräiset kasiot tuolta jälkimmäisestä polusta niin loppui virhe ilmoittelut.

 

Jaa viesti


Link to post
Jaa muulla sivustolla

Mulla oli muistaakseni joskus samanlaista ongelmaa. Mulla se aiheutui samannimisistä koneista eri kansioissa. Eli FSX:n koneet on normaalisti siellä "Microsoft Flight Simulator X\SimObjects\Airplanes" kansiossa, mutta jostainsyystä mulla oli mennyt jotain koneita "Microsoft Flight Simulator X\Airplanes" kansioon. Poistin ylimääräiset kasiot tuolta jälkimmäisestä polusta niin loppui virhe ilmoittelut.

 

Mulla ei ole tollasta "Microsoft Flight Simulator X\Airplanes" -kansiota. On vain tuolla SimObjectsissa. Kattelin parista kansiosta tuolta "Microsoft Flight Simulator X\SimObjects\UT2 Aircraft" -kansiosta noita aircraft.cfg filuja, ja ei siellä kyllä ole yhdessäkään sama nimi kohdassa "title=" :-\

 

Tässä vielä kuva yhdestä filusta:

 

[ attachment removed / expired ]

 

 

Tuo simu käy siis läpi kaikki tuossa kansiossa olevat kansiot, tai ainakin suurimman osan. Jokaisessa olevinaan tuo "multiple objects"... mutta missään noissa cfg:ssä ei ole yhtään nimeä kahta kertaa...

Jaa viesti


Link to post
Jaa muulla sivustolla

Oletko kokeillut ajaa ACA2007 Lightin? Se on hyvä työkalu noiden virheiden jahtaamiseen.

http://aifs.pvdveen.net/download.htm

Kiitos vinkistä! Ajoin tuon ja hetihän se löysi, ilmeisesti samat [fltsim.x] -numerot on kahteen kertaan! Täytyy korjata ja kattella uudestaan.. 8)

 

Hm... tuo ACA löytää kaksi noita mutta minä en ?

 

Duplicate use of sim title: F1UT2_100_Daedalus

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.0]

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.0]

Duplicate use of sim title: F1UT2_100.2M.2M

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.1]

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.1]

.......

 

En vaan löydä mistään kahta kertaa noita?

Jaa viesti


Link to post
Jaa muulla sivustolla

Eli avasit tiedoston Aircraft.cfg kansiosta ..\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100\

 

Ja tarkistit että siellä oli seuraavia rivejä vain yksi kappale:

title=F1UT2_100_Daedalus

title=F1UT2_100.2M.2M

Jaa viesti


Link to post
Jaa muulla sivustolla

Eli avasit tiedoston Aircraft.cfg kansiosta ..\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100\

 

Ja tarkistit että siellä oli seuraavia rivejä vain yksi kappale:

title=F1UT2_100_Daedalus

title=F1UT2_100.2M.2M

Kyllä, juuri näin.

Jaa viesti


Link to post
Jaa muulla sivustolla

Voit tietysti yrittää etsiä noita kahta riviä windowsin omalla etsintä työkalulla tiedostojen sisältä. Itse en saanut sitä Vistassa toimimaan, tumpelo kun olen.  ;D

Jaa viesti


Link to post
Jaa muulla sivustolla

Voit tietysti yrittää etsiä noita kahta riviä windowsin omalla etsintä työkalulla tiedostojen sisältä. Itse en saanut sitä Vistassa toimimaan, tumpelo kun olen.  ;D

 

Windowsien etsintätyökalut (ja explorer-ohjelma) ovat nekin vähän tumpeloita, kun pitää löytää joki merkkijono jostain. Esimerkiksi tästä osoitteesta: http://www.freecommander.com/ löytyy hyvä tiedostojen hallinta- ja etsintätyökalu, joka hakkaa Windowsin vastaavat mennen tullen - eikä maksa mitään. Muitakin on olemassa.

 

Pekka

 

Jaa viesti


Link to post
Jaa muulla sivustolla

...

Hm... tuo ACA löytää kaksi noita mutta minä en ?

 

En vaan löydä mistään kahta kertaa noita?

 

Onko sulla siellä aircraft.cfg-tiedostossa tuplarivejä tai sitten vaihtoehtoisesti sama kone (ja sama title-rivi) konekansiossa kahteen kertaan (eri nimellä)?

 

 

Jaa viesti


Link to post
Jaa muulla sivustolla

Onko sulla siellä aircraft.cfg-tiedostossa tuplarivejä tai sitten vaihtoehtoisesti sama kone (ja sama title-rivi) konekansiossa kahteen kertaan (eri nimellä)?

 

 

Ei ole, ihme kun tuo asentaa ite sitten tollee sen. Aina poistanut kaikki vanhat tiedostot joka paikasta ennenkuin asentanut uudelleen. Ja eikä se ole vain noi kaksi riviä, vaan kaikki koneet jotka tuo asentaa..

 

Tässä vielä molemmista:

 

[ attachment removed / expired ]

 

ja sama tuosta ACAsta:

 

Duplicate use of sim title: F1UT2_100_Daedalus

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.0]

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.0]

Duplicate use of sim title: F1UT2_100.2M.2M

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.1]

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.1]

Duplicate use of sim title: F1UT2_100.AE.AE

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.2]

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.2]

Duplicate use of sim title: F1UT2_100.AF.AF

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.3]

   C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\SimObjects\UT2 Aircraft\100 - [fltsim.3]

 

??? ??? :-\

Jaa viesti


Link to post
Jaa muulla sivustolla

Hmm, en ole varma kun en ole vielä testannut mutta taisin keksiä ratkaisun! Eli, fsx.cfg:ssä oli kaksi kertaa [Main] -kohdassa rivi "SimObjectPaths.6=SimObjects/UT2 Aircraft" tjsp. Poistin vielä kerran koko ohjelman kun rupesi herjaamaan jostain invalid licensestä vaikka on ihan aito tuote. Sitten tutkiskelin tuolla noita ACA:n näyttämiä muita virheitä, sain korjattua kaikki (Kiitokset Mikolle vielä linkistä!). Katsoin myös FSX.cfg:n ja sieltähän paljastui kaks riviä noita... :thmbup: Nyt asennan takas ja katsotaan pelittääkö... 8)

 

 

 

EDIT: Jea, "No errors found." Olen jumal! ;D

Jaa viesti


Link to post
Jaa muulla sivustolla

Luo uusi käyttäjätunnus tai kirjaudu sisään

Sinun täytyy olla jäsen osallistuaksesi keskusteluun

Luo käyttäjätili

Rekisteröi uusi käyttäjätili helposti ja nopeasti!


Luo uusi käyttäjätili

Kirjaudu sisään

Sinulla on jo käyttäjätili?


Kirjaudu sisään